分析家公式网,免费股票公式,股票软件下载站 用户登录  |  用户注册
五里判官(做多、做空、强洗、弱升)
  • 软件大小:11.0 KB
  • 推荐星级:
  • 更新时间:2011-01-28 05:25:31
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/
  • 相关Tags:五里判官(做多、做空、强洗、弱升)  
  • (3)43%
    (4)57%

软件简介

五里判官(做多、做空、强洗、弱升)-指标公式源码

N1:=5;
N2:=10;
N3:=20;
N4:=30;
P:=2;
M:=20;
N:=250;
M1:=55;
W:=21;
P3:=500;
N9:=90;
HR:=HHV(HIGH,M1);
HRY:=LLV(LOW,M1);
HRY11:=HR*HRY;
HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2;
IF(C>HRY33 AND HRY33 >=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK2,COLORRED;
MA1:EMA(CLOSE,N1);
MA2:EMA(CLOSE,N2);
MA3:EMA(CLOSE,N3),COLOR00FFFF;
MA4:EMA(CLOSE,N4),LINETHICK2;
TJ1:=CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;
TJ2:=(MAX(MA1,MAX(MA2,MA3))-MIN(MA1,MIN(MA2,MA3)))/
MIN(MA1,MIN(MA2,MA3))*100<=P;
XG:=TJ1 AND TJ2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
做多:=IF(K>D AND MACD>0 AND V>1,2,0),COLORRED;
做空:=IF(K<D AND MACD<0 AND V>1,-2,0),COLOR00FF00;
强洗:=IF(MACD>0 AND K<D AND V>1,1,0),COLOR0099FF;
弱升:=IF(MACD<0 AND K>D AND V>1,-1,0),COLORFFFF00;
STICKLINE(做多 AND C>=O,C,O,3,1),COLORRED;
STICKLINE(做多 AND C<O,C,O,3,0),COLOR990099;
STICKLINE(做多 AND C<O,C,O,1,0),COLORCC00CC;
STICKLINE(做多 AND C<O,C,O,0.3,0),COLORFF00FF;
STICKLINE(做多 AND C>=O,C,O,3,1),COLOR0000FF;
{STICKLINE(做多 AND C>=O,C,O,1.5,0),COLOR0000DD;
STICKLINE(做多 AND C>=O,C,O,0.4,0),COLOR0000FF;}
STICKLINE(做空 AND C>=O,L,H,0.1,0),COLOR0000FF;
STICKLINE(做空 AND C>=O,C,O,3,1),COLOR00FF00;
{STICKLINE(做空 AND C<O,C,O,3,0),COLOR00FF00;
STICKLINE(做空 AND C<O,C,O,0.3,0),COLOR00FF00;
STICKLINE(做空 AND C<O,C,O,0.3,0),COLOR00FF00;}
STICKLINE(强洗 AND C>=O,L,H,0.1,0),COLOR0000FF;
STICKLINE(强洗 AND C>=O,C,O,3,1),COLORFFFFFF;
STICKLINE(强洗 AND C<O,C,O,3,0),COLOR999999;
STICKLINE(强洗 AND C<O,C,O,1,0),COLORCCCCCC;
STICKLINE(强洗 AND C<O,C,O,0.3,0),COLORFFFFFF;
STICKLINE(弱升 AND C>=O,C,O,3,1),COLOR00FFFF;
STICKLINE(弱升 AND C<O,C,O,3,0),COLOR009999;
STICKLINE(弱升 AND C<O,C,O,0.3,0),COLOR00FFFF;

STICKLINE(FILTER(TJ1,3),C,O,4,0),COLOR0000FF;
DRAWICON(FILTER(XG,3),L*0.985,23);
GET:=ZIG(3,3),COLORYELLOW;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(A)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFF00FF;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(C)'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.05,'Ⅱ'),COLORFFFF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'①'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,'③'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'④'),
LINETHICK3,COLOR00FFFF;
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;

MM:=C>HRY33 AND HRY33 >=REF(HRY33 ,1);
QQ:=HRY33>=REF(HRY33 ,1);
XG11:=CROSS(C,HRY33)  AND QQ AND MM;
BUY1:=LAST(CLOSE>MA(CLOSE,55),0,5);
BUY2:=EXIST(CLOSE<MA(CLOSE,55),5);
BUY:=CLOSE>MA(CLOSE,55)&&BUY1&&BUY2;
W18:=FILTER(EXIST(XG11 OR BUY,1),5);
STICKLINE(W18,C,(C+O)/2,4,0),COLORFF00FF;
DRAWTEXT(W18,L*0.97,'牛'),COLOR00FFFF;
X1:=REF(C,1)/HHV(H,20)<0.82;
X2:=(MIN(C,O)-L)/(H-L)>0.67;
X3:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)<0.33;
X4:=ABS(C-O)/C<0.01;
DOWN:=O>C;
X5:=COUNT(DOWN,7)>=5;
XG8:=X1 AND X2 AND X3 AND X4 AND X5;
DRAWTEXT(XG8,L*0.98,'螺'),COLOR00FFFF;
AA:=REF(C,1)/REF(O,1)<0.96;
BB:=C/O>1.03;
CC:=C>REF(O,1);
TJ81:=AA AND BB AND CC;
X81:=REF(C,1)/HHV(H,20)<0.82;
DN:=O>C;
X82:=COUNT(DN,7)>=5;
X83:=C=HHV(C,3);
XG81:=TJ81 AND  X81 AND X82;
XG82:=X81 AND X82 AND X83;
XG88:=XG81 OR XG82;
DRAWTEXT(XG88,L*0.96,'反'),COLOR00FFFF;
X01:=REF(C,1)/HHV(H,21)<0.77;
{DOWN1:=O>C;
X02:=COUNT(DOWN1,9)>=6;}
X03:=ABS(C-O)/C<0.008;
X04:=(H-L)/C>0.025;
XG0:=X01  AND X03 AND X04;
DRAWTEXT(XG0,L*0.97,'星'),COLOR00FFFF;
S1:=REF(C,1)/LLV(L,W)>1.30;
S2:=(H-MAX(C,O))/(H-L)>0.60;
S3:=ABS(C-O)/C<0.03;
S4:=(H-O)/C>0.05 AND C<O;
SAL1:=S1 AND S2 AND S3;
SAL2:=S1 AND ABS(C-O)/C>0.05 AND C<O;
SAL3:=S1 AND ABS(C-O)/C<0.001;
SAL4:=S1 AND S4;
SAL5:=(H-MAX(C,O))/(H-L)>0.67 AND C<O AND S3;
SAL:=SAL1 OR SAL2 OR SAL3 OR SAL4 OR SAL5;

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
黄买:=FILTER((REF(CLOSE,2)<CLOSE AND RSI<25),7);
黄卖:=FILTER((REF(CLOSE,2)>CLOSE AND RSI>80),7);
红买:=FILTER(CROSS(RSI,11),7);
红卖:=FILTER(CROSS(89,RSI),7);
绿买:=FILTER(CROSS(RSI,20),7);
绿卖:=FILTER(CROSS(80,RSI),7);
SL1:=红卖 AND 绿卖;
SL2:=红卖 AND 绿卖 AND 黄卖;
BU:=红买 AND 绿买;
SS1:=CROSS(MA(C,5),C);
SS2:=(REF(C,1)-C)/REF(C,1)>0.04;
SS3:=O<REF(C,1);
JJ1:=SS1 AND SS2 AND SS3;
SSL:=JJ1 AND S1;
SAL8:=FILTER(SAL OR SSL,5);
DRAWTEXT(SAL8 OR SL1 OR SL2,H*1.02,'卖'),COLOR00FF00;
STICKLINE(SAL8 OR SL1 OR SL2,C,O,1,0),COLORFF0000;
DRAWTEXT(SAL8 AND SL1 AND SL2,H*1.02,'必卖'),COLOR00FF00;
MA20:=MA(CLOSE,20);
AA10:=MA(CLOSE,8);
中期大底:=LLV(LOW,30);
支撑:=HHV(EMA(((((OPEN + LOW) + HIGH) + CLOSE) / 4),5),60);
压力一:=HHV(LOW,20);
中线:=MA(CLOSE,3);
天:=(MA(LOW,15) * 0.985);
人:=(MA(LOW,15) * 0.96);
地:=(((HIGH + LOW) + CLOSE) / 3);
B1:=HHV(地,(4 * 15));
B6:=LLV(地,(4 * 15));
B7:=(B1 - B6);
B8:=(MA(((地 - B6) / B7),2) * 80);
短期底部:=(LLV(HIGH,30) * 0.93);
MA80:=LLV(HIGH,30);
压力二:=(SMA(HIGH,21,2) * 1.035);
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RSV8:=SMA(下档线,3,1);
K8:=SMA(RSV8,3,1);
D8:=((3 * RSV8) - (2 * K8));
J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(SMA(J12,3,1),3,1);
D24:=((3 * SMA(J12,3,1)) - (2 * K24));
压力位:=IF(CROSS(D24,D),HIGH,L);
长期底部:=LLV(HIGH,30);
X18:=EMA((((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6),10);
逃遁:=(SMA(HIGH,21,2) * 1.05);
TJ18:=FILTER(((((LLV(LOW,0) AND ((MA(CLOSE,37) - REF(MA(CLOSE,37),1))
> 0)) AND (LOW <= 短期底部)) AND (WINNER(CLOSE) < 0.05)) AND
((CLOSE / OPEN)> 0.13)),7);
阻挡:=(SMA(LOW,21,2) * 0.94);
TJ28:=FILTER(((((((((CLOSE / OPEN) > 1.03) AND ((MA(CLOSE,15) -
REF(MA(CLOSE,15),1)) > 0)) AND ((CLOSE - REF(CLOSE,1)) > 0))
AND (HIGH < 压力一)) AND (CLOSE < 压力一)) AND ((压力二 -
REF(压力二,1)) > 0)) AND (CLOSE < (SMA(HIGH,21,2) * 1.05))),3);
TJ38:=FILTER(((((((LOW <= 天) AND (CLOSE >= MA20)) AND (HIGH < 压力一))
AND ((天 - REF(天,1)) > 0)) AND (CLOSE < 压力一)) AND ((MA20 -
REF(MA20,1)) > 0)),6);
TJ4:=LOW <= (SMA(LOW,5,2) * 0.96 AND HIGH >= 短期底部 AND
CLOSE >= 长期底部 AND CLOSE / OPEN) > 1.03;
TJ5:=FILTER((((CROSS((MA(LOW,10) * 0.96),(EMA(OPEN,107) * 0.897))
AND (HIGH < MA(CLOSE,80))) AND (HIGH < 压力一)) AND LLV(LOW,0)),10);
红轨道:=MA(MA(CLOSE,3),1);
绿轨道:=MA(MA(CLOSE,3),3);
AA1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
加仓:=IF(CROSS(AA1,REF(AA1+0.01,1)) AND LLV(AA1,2)=LLV(AA1,8) AND BETWEEN(AA1,20,60),1,0);
波段底:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) -
(2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
TJ68:=加仓;
XG1:=TJ18 OR TJ28 OR TJ38 AND TJ68;
STICKLINE(XG1,O,(C+O)/2,4,0)COLOR00FFFF;
E1:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
B0:=(AH-AL)/40;
KB1:=H+B0;
KB2:=L-B0;
SJCK:=(E1+0)/34=FLOOR((E1+0)/34);
STICKLINE(SJCK,KB2,KB2-0.8*B0,1,0),COLORYELLOW,LINETHICK3;
DRAWTEXT(SJCK,KB2-B0,'时'),COLORYELLOW;
SJ:=EXIST(SJCK,5);
水平面:=EMA(CLOSE,89);
AAA:=(3*C+H+L+O)/6;
短趋:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
中趋:=(LLV(短趋,2)+LLV(短趋,4)+LLV(短趋,6))/3;
TTJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>短趋;
立桩量:=FILTER(TTJ1,5);
TTJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TTJ2=1;
TTJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TTJ3=1;
成立:=三天法则 AND 突破;
X8:=REF(C,1)/HHV(H,P3)<0.50;
条件成立:=FILTER(成立,3) AND X8 AND C>HRY33;
STICKLINE(条件成立,C,O,0.5,0),COLOR00FFFF;
W168:=XG22 OR XG0  OR XG8 OR XG88 AND SJ;
STICKLINE(W168,C,O,4,0),COLOR0000FF;
DRAWICON(W168,L*0.98,26);

A:=EMA(EMA(EMA(HIGH,7),7),1);
B:=A*0.81;
TJ19:=FILTER(COUNT(L<B,3)>=2,3);
D9:=A*0.87;
TJ29:=FILTER(LAST(C<D9,3,3),3);
XG9:=TJ19 OR TJ29;
STICKLINE(XG9,C,O,3,0),COLOR00FFFF;
DRAWTEXT(XG9,L*0.97,'全仓'),COLORFFFFFF;
K7:=BARSLAST(CURRBARSCOUNT=N9);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K7),0));
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K7),0));

ZW:=(GD+DD)/2;JC:=(GD-DD);
DRAWTEXT(CURRBARSCOUNT=N9,ZW-JC/1.3,'★五里警告:纪律、止损、趋势第一!人脑服从电脑,坚决执行信号!'),COLOR00FFFF;


 

下载地址(点击上图是广告,点击下图进入下载地址网页)

    五里判官(做多、做空、强洗、弱升)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网发布的公式指标和股票软件绝大部分是来源于各大论坛,例如:理想论坛,老钱庄,创幻,MACD等论坛,谢谢各位老师的原创软件。为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.61才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
* tnc和tni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne格式公式,仅可以用通达信公式编辑器5.0版导入,推荐通达信普天同庆(Ⅵ)版本,高版本兼容低版本;
* hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费破解FNC大智慧公式;破 解hxf同花顺,daf操盘手,alg飞狐等原码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含破解及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

特别声明:本站不招任何收费会员,站内所有广告其网站的一切言行均与本站无关,请广大网友小心谨慎。
Copyright © 2003-2008 88GS.Com. All Rights Reserved .
页面执行时间:4,281.25000 毫秒
网站备案信息:苏ICP备12037878号