分析家公式网,免费股票公式,股票软件下载站 用户登录  |  用户 注册
重发【量价突破】(广角量价突破、主买成交量、KDJ自编、MACD自编、分时主图、选股预警公式)
  • 软件大小:11.0 KB
  • 推荐星级:
  • 更新时间:2017-10-13 00:52:05
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:量价突破  
  • (0)0%
    (0)0%

==

重发指标,是原贴下载链接失效,网友要求,就重新发布一次。

  【量价突破】指标(广角量价突破 主买成交量、KDJ自编、MACD自编、分时主图、选股预警公式)

 

{公式名称: 主买成交量
参数数量: 1
参数1: 前高ZIG, 最小: 1, 最大: 99, 缺省: 2
画线方法: 副图
}
 
NOTEXTGGG:VOL*1.6,COLORBLACK;
DRAWGBK(CLOSE>1,RGB(0,0,0),RGB(1,1,1),1,0,0);
VAR1:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
VAR2:=MOD(FROMOPEN,VAR1);
VAR3:=IF(VAR2<0.5,VAR1,VAR2);
VAR4:=IF(CURRBARSCOUNT=1 AND DYNAINFO(8)>1,VOL*VAR1/VAR3,DRAWNULL);
虚拟VS昨量:VAR4/REF(VOL,1),NODRAW,COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1 AND DYNAINFO(8)>1,VAR4,0,(-1),(-1)),COLORYELLOW;
量:VOL,VOLSTICK;
{http://www.88gs.com}
VAR5:=ACTINVOL-ACTOUTVOL;
STICKLINE(1,IF(VAR5>0,VAR5,DRAWNULL),0,2,0),COLORRED;
STICKLINE(VOL>=REF(VOL,1)*1.8 AND CLOSE>REF(CLOSE,1) AND CLOSE>OPEN,VOL*0.98,0,0.1,0),COLORYELLOW;
STICKLINE(VOL<=REF(VOL,1)/2,VOL*0.98,0,0.1,0),COLORBLUE;
VAR6:=MA(VOL,5);
VAR7:=MA(VOL,20);
VAR8:=ZIG(HIGH,4);
VAR9:=REF(VAR8,1)<REF(VAR8,2) AND VAR8>REF(VAR8,1);
VAR10:=IF(VAR8>REF(VAR8,1) AND ISLASTBAR,CONST(SUMBARS(VAR9,2)),CONST(SUMBARS(VAR9,1)));
VAR11:=CONST(LLVBARS(VOL,VAR10));
VAR12:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR13:=SMA(VAR12,3,1);
VAR14:=SMA(VAR13,3,1);
VAR15:=3*VAR13-2*VAR14;
{www.88gs.com}
VAR16:=CROSS(VAR15,VAR14) AND EXIST(VAR15<55,3);
VAR17:=VAR16 AND CLOSE>REF(CLOSE,1) AND CLOSE>OPEN;
DRAWICON(VAR17 AND CURRBARSCOUNT>1 AND CURRBARSCOUNT<=VAR11+1,VOL*1.35,11);
DRAWICON(VAR17 AND ISLASTBAR,VAR4*1.35,11);
VAR18:=ZIG(1,前高ZIG);
VAR19:=VAR18<REF(VAR18,1) AND REF(VAR18,1)>REF(VAR18,2);
VAR20:=IF(CONST(SUMBARS(VAR19,1))<=1,CONST(SUMBARS(VAR19,2)),CONST(SUMBARS(VAR19,1)));
{分析家公式网www.88gs.com}
VAR21:=CONST(REF(VOL,VAR20));
NOTEXT横线:IF(CURRBARSCOUNT<=VAR20+1,VAR21,DRAWNULL),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=VAR20+1,NOTEXT横线*0.9,112),COLORGREEN,LINETHICK9;


{公式名称: 广角量价突破
 
参数数量: 4
参数1: 高点算1低点算2, 最小: 1, 最大: 2, 缺省: 2
参数2: 显必杀线1, 最小: 0, 最大: 1, 缺省: 0
参数3: 前高ZIG, 最小: 1, 最大: 99, 缺省: 2
参数4: 显布林1, 最小: 0, 最大: 1, 缺省: 0
 
画线方法: 主图叠加
 
用法注释:
费布拉楔时间窗口调整方法:
自己可以选择从高点算起,还是从低点算起,也可改成参数形式:改参数为1,则从高点算起;改参数为2,则从低点算起{http://www.88gs.com}
公式源码:}
 
VAR1:=0.85;
VAR2:=INBLOCK(119);
VAR3:=IF(VAR2,VAR1-0.075,0.85);
上影线%:(HIGH-MAX(OPEN,CLOSE))/MAX(OPEN,CLOSE)*100,NODRAW,COLORYELLOW;
NOTEXTGGG1:HIGH*1.098,COLORBLACK;
NOTEXTGGG2:MAX(CONST(ZTPRICE(CLOSE,0.1)),CONST(ZTPRICE(REF(CLOSE,1),0.1)))*1.08,COLORBLACK;
NOTEXTLLL:MIN(LOW*0.92,CONST(DTPRICE(REF(CLOSE,1),0.1))*0.98),COLORBLACK;
DRAWGBK(CLOSE>1,RGB(0,0,0),RGB(1,1,1),1,0,0);
VAR4:=IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,CONST(今明涨跌价.今涨停#DAY));
VAR5:=IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,CONST(今明涨跌价.今跌停#DAY));
VAR6:=IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,CONST(今明涨跌价.明涨停#DAY));
{www.88gs.com}
VAR7:=5;
VAR8:=10;
VAR9:=IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,IF(NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) OR NAMELIKE(4),CLOSE*VAR7/100+CLOSE,CLOSE*VAR8/100+CLOSE));
STICKLINE(IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),0,ISLASTBAR AND DYNAINFO(10)>0),VAR4,VAR5,3.8,1),COLORWHITE;
STICKLINE(IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),0,ISLASTBAR AND DYNAINFO(10)>0),VAR6,IF(VAR6>=VAR4,VAR4,CONST(CLOSE)),3.8,0),COLORA4A4FF;
VAR10:=MA(CLOSE,20);
VAR11:=POW(CLOSE-VAR10,2);
VAR12:=MA(VAR11,20);
VAR13:=SQRT(VAR12);
VAR14:=VAR10+2*VAR13;
VAR15:=VAR10-2*VAR13;
上:IF(显布林1=1,REF(VAR14,1),DRAWNULL),COLORWHITE;
中:IF(显布林1=1,REF(VAR10,1),DRAWNULL),COLORWHITE;
下:IF(显布林1=1,REF(VAR15,1),DRAWNULL),COLORWHITE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.6,0),COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.1,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.9,0),COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0),COLORRED;
STICKLINE(CLOSE>OPEN,HIGH,LOW,0,0),COLORRED;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLOR646400;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.6,0),COLOR848400;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.1,0),COLOR9F9F00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.5,0),COLORB0B000;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.9,0),COLORC4C400;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.1,0),COLORDBDB00;
STICKLINE(CLOSE<OPEN,HIGH,LOW,0,0),COLORDDDD00;
STICKLINE(CLOSE=OPEN,CLOSE,OPEN,3,0),COLORWHITE;
STICKLINE(CLOSE=OPEN,HIGH,LOW,0,0),COLORWHITE;
VAR16:=CLOSE>=INTPART(REF(CLOSE,1)*1.1*100)/100;
VAR17:=CLOSE>=INTPART(REF(CLOSE,1)*1.05*100)/100;
VAR18:=IF(NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) OR NAMELIKE(4),VAR17,VAR16);
STICKLINE(IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,VAR18 AND PERIOD=5 AND OPEN!=HIGH),(((OPEN+CLOSE)/2+OPEN)/2+OPEN)/2,(((OPEN+CLOSE)/2+CLOSE)/2+CLOSE)/2,0.005,0),COLORYELLOW;
VAR19:=IF(NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) OR NAMELIKE(4),CLOSE=DTPRICE(REF(CLOSE,1),0.05),CLOSE=DTPRICE(REF(CLOSE,1),0.1));
STICKLINE(IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,VAR19 AND PERIOD=5 AND OPEN!=LOW),(((OPEN+CLOSE)/2+OPEN)/2+OPEN)/2,(((OPEN+CLOSE)/2+CLOSE)/2+CLOSE)/2,0.005,0),COLORBLUE;
STICKLINE(ISLASTBAR AND PERIOD=5,IF(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,DYNAINFO(11)),IF(CODELIKE(120) OR CODELIKE(121) OR NAMELIKE(22),DRAWNULL,DYNAINFO(11)),3.8,0),COLORWHITE;
DRAWICON(上影线%>=3 AND PERIOD=5 AND NOT(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22)),HIGH*1.018,41);
VAR20:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR21:=NOT(CODELIKE(120) OR CODELIKE(121) OR CODELIKE(21) OR NAMELIKE(22));
DRAWTEXT(ISLASTBAR AND VAR21 AND DYNAINFO(10)>1 AND PERIOD=5,HIGH*1.01,122),COLORWHITE;
DRAWTEXT(ISLASTBAR AND VAR21 AND HIGH=ZTPRICE(REF(CLOSE,1),0.1) AND DYNAINFO(10)>1 AND PERIOD=5,HIGH*1.01,122),COLORRED;
DRAWTEXT(ISLASTBAR AND VAR21 AND DYNAINFO(10)>1 AND PERIOD=5,HIGH*1.024,IF(VAR20>0,STRCAT(STRCAT(123,CON2STR(VAR20,2)),11),STRCAT(STRCAT(124,CON2STR(VAR20,2)),11))),COLORWHITE;
DRAWTEXT(ISLASTBAR AND VAR21 AND HIGH=ZTPRICE(REF(CLOSE,1),0.1) AND DYNAINFO(10)>1 AND PERIOD=5,HIGH*1.024,IF(VAR20>0,STRCAT(STRCAT(123,CON2STR(VAR20,2)),11),STRCAT(STRCAT(124,CON2STR(VAR20,2)),11))),COLORRED;
VAR22:=ZIG(1,前高ZIG);
VAR23:=VAR22<REF(VAR22,1) AND REF(VAR22,1)>REF(VAR22,2);
VAR24:=IF(CONST(SUMBARS(VAR23,1))<=1,CONST(SUMBARS(VAR23,2)),CONST(SUMBARS(VAR23,1)));
VAR25:=CONST(REF(HIGH,VAR24));{http://www.88gs.com}
NOTEXT正确横线:IF(CURRBARSCOUNT<=VAR24+1,VAR25,DRAWNULL),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=VAR24+1,NOTEXT正确横线*0.995,STRCAT(125,CON2STR(NOTEXT正确横线,2))),COLORGREEN,LINETHICK9;
VAR26:=CONST(REF(VOL,VAR24));
{分析家公式网www.88gs.com}
VAR27:=IF(CURRBARSCOUNT<=VAR24+1,VAR26,DRAWNULL);
VAR28:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR29:=EMA(VAR28,9);
VAR30:=(VAR28-VAR29)*2;
VAR31:=EVERY(VAR30>REF(VAR30,1),2) AND VAR28>VAR29 OR EVERY(VAR28>VAR29,5) AND (VAR28>CONST(REF(VAR28,VAR24)) OR VAR30>CONST(REF(VAR30,VAR24))) AND VAR28>REF(VAR28,1);
VAR32:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR33:=SMA(VAR32,3,1);
VAR34:=SMA(VAR33,3,1);
VAR35:=3*VAR33-2*VAR34;
VAR36:=VAR35<107 AND VAR35>REF(VAR35,1);
VAR37:=(HIGH-MAX(OPEN,CLOSE))/MAX(OPEN,CLOSE)*100<2.5;
VAR38:=CROSS(CLOSE,NOTEXT正确横线) AND VOL>VAR27 AND VAR31 AND VAR36 AND VAR37 AND VOL>=REF(VOL,1) AND CLOSE>REF(CLOSE,1) AND CLOSE>OPEN AND (REF(CLOSE,1)-REF(CLOSE,2))/REF(CLOSE,2)*100<5 AND LLV(LOW,5)>=LLV(LOW,13) AND LLV(LOW,13)>=LLV(LOW,34);
DRAWICON(VAR38,LOW*0.95,34);
VAR39:=CONST(BARSLAST(VAR38));
VAR40:=CONST((CONST(HHV(HIGH,VAR39+1))-MAX(NOTEXT正确横线,CONST(REF(OPEN,VAR39))))/MAX(NOTEXT正确横线,CONST(REF(OPEN,VAR39)))*100);
DRAWTEXT_FIX(EXIST(VAR38,120),0.4,0.088,0,126),COLORRED;
DRAWTEXT_FIX(EXIST(VAR38,120),0.4,0.088,0,STRCAT(STRCAT(127,CON2STR(VAR40,2)),128)),COLORYELLOW;
VAR41:=0;
VAR42:=0.36;
VAR43:=IF(高点算1低点算2=1,PEAKBARS(1,13,1),TROUGHBARS(2,13,1));
VAR44:=VAR43=5 OR VAR43=8 OR VAR43=13 OR VAR43=21 OR VAR43=34 OR VAR43=55 OR VAR43=89 OR VAR43=144 OR VAR43=233 OR VAR43=377 OR VAR43=610;
DRAWTEXT(VAR44 AND CURRBARSCOUNT<=CONST(VAR43),LOW*0.98,VAR2STR(VAR43,0)),COLORWHITE;
VAR45:=STRCAT(STRCAT(129,CON2STR(VAR43,0)),130);{http://www.88gs.com}
VAR46:=IF(VAR43=5,131,IF(VAR43=8,132,IF(VAR43=13,133,IF(VAR43=21,134,IF(VAR43=34,135,IF(VAR43=55,136,IF(VAR43=89,137,IF(VAR43=144,138,IF(VAR43=233,139,IF(VAR43=377,140,IF(VAR43=610,141,VAR45)))))))))));
VAR47:=IF(VAR43<10,6,IF(VAR43>=10 AND VAR43<100,7,IF(VAR43>=100,52,DRAWNULL)));
DRAWTEXT_FIX(ISLASTBAR,VAR42,VAR41,0,VAR47),COLORBLUE;
VAR48:=IF(VAR44 AND VAR43<10,7,IF(VAR44 AND VAR43>10 AND VAR43<100,52,IF(VAR44 AND VAR43>100,53,DRAWNULL)));
DRAWTEXT_FIX(ISLASTBAR,VAR42,VAR41,0,VAR48),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,VAR42+0.012,VAR41,0,VAR46),COLORWHITE;
DRAWTEXT_FIX(高点算1低点算2=1,0,0,0,142),COLORRED;
DRAWTEXT_FIX(高点算1低点算2=2,0,0,0,142),COLORBLUE;
DRAWTEXT_FIX(高点算1低点算2=1,0,0,0,143),COLORYELLOW;
DRAWTEXT_FIX(高点算1低点算2=2,0,0,0,144),COLORWHITE;
VAR49:=CONST(LLVBARS(LOW,10));
VAR50:=CONST(REF(HIGH,VAR49));
VAR51:=CONST(CURRBARSCOUNT);
VAR52:=CONST(BARSLAST(CURRBARSCOUNT>VAR51+VAR49 AND HIGH>VAR50));
VAR53:=CONST(REF(HIGH,VAR52));
VAR54:=CONST(BARSLAST(CURRBARSCOUNT>VAR51+VAR52 AND HIGH>VAR53));
VAR55:=CONST(REF(HIGH,VAR54));
NOTEXT必杀线:IF(显必杀线1=1,DRAWLINE(CURRBARSCOUNT=VAR54+1,VAR55,ISLASTBAR,VAR55,1),DRAWNULL),DOTLINE,COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=VAR54+1,NOTEXT必杀线*0.99,STRCAT(145,CON2STR(NOTEXT必杀线,2))),COLORYELLOW,LINETHICK9;
VAR56:=STRCAT(16,DYBLOCK);
VAR57:=STRCAT(VAR56,17);
{分析家公式网www.88gs.com}
VAR58:=STRCAT(VAR57,HYBLOCK);
VAR59:=STRCAT(VAR58,18);
DRAWTEXT_FIX(IF(CODELIKE(19) OR CODELIKE(20) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,1),0,0.08,0,VAR59),COLORCYAN;
VAR60:=DDE数据.机构净买量#DAY;
VAR61:=DDE数据.超大#DAY;
VAR62:=DDE数据.大单#DAY;
VAR63:=DDE数据.中单#DAY;
VAR64:=DDE数据.小单#DAY;
VAR65:=IF(VAR60>=0,1,0);
VAR66:=IF(VAR61>=0,1,0);
VAR67:=IF(VAR62>=0,1,0);
VAR68:=VAR65+VAR66+VAR67;
VAR69:=VAR61>=0 AND VAR62>=0 AND VAR60>=0;
VAR70:=VAR68<3 AND VAR68>0;
VAR71:=VAR68=0;
VAR72:=0;
VAR73:=1;
VAR74:=PERIOD=6 OR PERIOD=5;
DRAWTEXT_FIX(ISLASTBAR AND VAR69=1 AND VAR74 AND DYNAINFO(10)>0,VAR72,VAR73,0,23),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND VAR69=1 AND VAR74 AND DYNAINFO(10)>0,VAR72,VAR73,0,24),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND VAR69=0 AND VAR74 AND DYNAINFO(10)>0,VAR72,VAR73,0,23),COLORGREEN;
VAR75:=IF(VAR70,25,26);
DRAWTEXT_FIX(ISLASTBAR AND VAR69=0 AND VAR74 AND DYNAINFO(10)>0,VAR72,VAR73,0,VAR75),COLORBLACK;
DRAWTEXT_FIX(ISLASTBAR AND DYNAINFO(10)>0,VAR72,VAR73,0,IF(MIN(VAR61,VAR62)>MAX(VAR63,VAR64) AND VAR60>0 AND VAR61>=0 AND VAR62>=0 AND DYNAINFO(10)>0 AND VAR74,27,DRAWNULL)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND DYNAINFO(10)>0,VAR72,VAR73,0,IF(MIN(VAR61,VAR62)<MAX(VAR63,VAR64) OR VAR60<0 OR VAR61<0 OR VAR62<0 AND DYNAINFO(10)>0 AND VAR74,27,DRAWNULL)),COLORFF8000;
DRAWTEXT_FIX(ISLASTBAR AND VAR61>=VAR62 AND VAR62>=VAR63 AND VAR63>=VAR64 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,28),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR61>=VAR62 AND VAR62>=VAR64 AND VAR64>=VAR63 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,29),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR61>=VAR63 AND VAR63>=VAR62 AND VAR62>=VAR64 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,30),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR61>=VAR63 AND VAR63>=VAR64 AND VAR64>=VAR62 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,31),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR61>=VAR64 AND VAR64>=VAR62 AND VAR62>=VAR63 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,32),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR61>=VAR64 AND VAR64>=VAR63 AND VAR63>=VAR62 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,33),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR62>=VAR61 AND VAR61>=VAR63 AND VAR63>=VAR64 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,34),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR62>=VAR61 AND VAR61>=VAR64 AND VAR64>=VAR63 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,35),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR62>=VAR63 AND VAR63>=VAR61 AND VAR61>=VAR64 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,36),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR62>=VAR63 AND VAR63>=VAR64 AND VAR64>=VAR61 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,37),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR62>=VAR64 AND VAR64>=VAR63 AND VAR63>=VAR61 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,38),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR62>=VAR64 AND VAR64>=VAR61 AND VAR61>=VAR63 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,39),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR63>=VAR61 AND VAR61>=VAR62 AND VAR62>=VAR64 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,40),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR63>=VAR61 AND VAR61>=VAR64 AND VAR64>=VAR62 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,41),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR63>=VAR62 AND VAR62>=VAR61 AND VAR61>=VAR64 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,42),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR63>=VAR62 AND VAR62>=VAR64 AND VAR64>=VAR61 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,43),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR63>=VAR64 AND VAR64>=VAR62 AND VAR62>=VAR61 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,44),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR63>=VAR64 AND VAR64>=VAR61 AND VAR61>=VAR62 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,45),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR64>=VAR61 AND VAR61>=VAR63 AND VAR63>=VAR62 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,46),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR64>=VAR61 AND VAR61>=VAR62 AND VAR62>=VAR63 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,47),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR64>=VAR62 AND VAR62>=VAR63 AND VAR63>=VAR61 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,48),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR64>=VAR62 AND VAR62>=VAR61 AND VAR61>=VAR63 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,49),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR64>=VAR63 AND VAR63>=VAR62 AND VAR62>=VAR61 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,50),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR64>=VAR63 AND VAR63>=VAR61 AND VAR61>=VAR62 AND DYNAINFO(10)>0 AND VAR74,VAR72,VAR73,0,51),COLORWHITE;
VAR76:=L2_AMO(0,2)/10000;
VAR77:=L2_AMO(1,2)/10000;
VAR78:=L2_AMO(0,3)/10000;
VAR79:=L2_AMO(1,3)/10000;
VAR80:=VAR76+VAR77-(VAR78+VAR79);
VAR81:=VAR80/AMOUNT*1000000;
VAR82:=0.5;
VAR83:=IF(CODELIKE(19) OR CODELIKE(20) OR CODELIKE(21) OR NAMELIKE(22),0,1);
DRAWTEXT_FIX(VAR81<0 AND DYNAINFO(10)>0 AND PERIOD=5 AND ISLASTBAR,VAR82,VAR83,0,IF(ABS(VAR81)<10,59,12)),COLORGREEN;
DRAWTEXT_FIX(VAR81<0 AND DYNAINFO(10)>0 AND PERIOD=5 AND ISLASTBAR,VAR82,VAR83,0,STRCAT(STRCAT(146,CON2STR(VAR81,2)),55)),COLORBLACK;
DRAWTEXT_FIX(VAR81>=0 AND DYNAINFO(10)>0 AND VAR81<10 AND PERIOD=5 AND ISLASTBAR,VAR82+0.002,VAR83,0,14),COLORRED;
DRAWTEXT_FIX(VAR81>=0 AND DYNAINFO(10)>0 AND VAR81<10 AND PERIOD=5 AND ISLASTBAR,VAR82,VAR83,0,STRCAT(STRCAT(146,CON2STR(VAR81,2)),55)),COLORBLUE;
DRAWTEXT_FIX(VAR81>=10 AND DYNAINFO(10)>0 AND PERIOD=5 AND ISLASTBAR,VAR82,VAR83,0,59),COLORRED;
DRAWTEXT_FIX(VAR81>=10 AND DYNAINFO(10)>0 AND PERIOD=5 AND ISLASTBAR,VAR82,VAR83,0,STRCAT(STRCAT(146,CON2STR(VAR81,2)),55)),COLORYELLOW;
VAR84:=0.767;{http://www.88gs.com}
VAR85:=CONST(每笔均量.量/每单买#DAY);
VAR86:=CONST(每笔均量.量/每单卖#DAY);
VAR87:=VAR85-VAR86;
VAR88:=IF(ABS(VAR87)<10,53,IF(ABS(VAR87)>=10 AND ABS(VAR87)<100,53,14));
DRAWTEXT_FIX(VAR85>VAR86 AND DYNAINFO(10)>0 AND ISLASTBAR,VAR84,1,0,VAR88),COLORMAGENTA;
DRAWTEXT_FIX(VAR85>VAR86 AND DYNAINFO(10)>0 AND VAR87>2 AND ISLASTBAR,VAR84,1,0,VAR88),COLORRED;
DRAWTEXT_FIX(VAR85>VAR86 AND DYNAINFO(10)>0 AND ISLASTBAR,VAR84,1,0,STRCAT(STRCAT(147,CON2STR(VAR87,2)),18)),COLORWHITE;
DRAWTEXT_FIX(VAR85<VAR86 AND DYNAINFO(10)>0 AND ISLASTBAR,VAR84,1,0,VAR88),COLORGREEN;
DRAWTEXT_FIX(VAR85<VAR86 AND DYNAINFO(10)>0 AND ISLASTBAR,VAR84,1,0,STRCAT(STRCAT(148,CON2STR(VAR87,2)),18)),COLORBLACK;
DRAWTEXT_FIX(VAR2 AND CONST(DAY)<=31,0,VAR1,0,149),COLORGREEN;
DRAWTEXT_FIX(VAR2 AND CONST(DAY)<=31,0.005,VAR1,0,IF(VAR2,EXTERNSTR(0,1),DRAWNULL)),COLORBLACK;
VAR89:=INBLOCK(150);
DRAWTEXT_FIX(VAR89 AND CONST(DAY)>=23,0,VAR3,0,149),COLOR008000;
DRAWTEXT_FIX(VAR89 AND CONST(DAY)>=23,IF(VAR89,0.005,DRAWNULL),VAR3,0,IF(VAR89,EXTERNSTR(0,2),DRAWNULL)),COLORBLACK;
VAR90:=大盘涨跌家数.沪市涨#DAY;
VAR91:=大盘涨跌家数.沪市跌#DAY;
VAR92:=大盘涨跌家数.深市涨#DAY;
VAR93:=大盘涨跌家数.深市跌#DAY;
VAR94:=VAR90+VAR92;
VAR95:=VAR91+VAR93;
VAR96:=VAR94/(VAR94+VAR95)*100;
VAR97:=VAR95/(VAR94+VAR95)*100;
VAR98:=STRCAT(STRCAT(56,CON2STR(VAR96,2)),11);
VAR99:=STRCAT(STRCAT(57,CON2STR(VAR97,2)),11);
VAR100:=IF(VAR94>VAR95 AND ISLASTBAR,VAR98,VAR99);
DRAWTEXT_FIX(VAR94>VAR95 AND ISLASTBAR,0.608,0,0,58),COLORRED;
DRAWTEXT_FIX(VAR94<VAR95 AND ISLASTBAR,0.608,0,0,58),COLORGREEN;
DRAWTEXT_FIX(VAR94>VAR95 AND ISLASTBAR,0.608,0,0,VAR100),COLORWHITE;
DRAWTEXT_FIX(VAR94<VAR95 AND ISLASTBAR,0.608,0,0,VAR100),COLORBLACK;
 


{公式名称: 分时前高主图
公式描述: -----分时主图
画线方法: 主图叠加
}
VAR1:=0.09;
NOTEXTGGG1:CONST(DYNAINFO(5))*1.04,COLORBLACK;
NOTEXTLLL1:CONST(DYNAINFO(6))*0.98,COLORBLACK;
VAR2:=CONST(前高引导公式.JSHX#DAY);
VAR3:=IF(VAR2<CONST(DYNAINFO(5))*1.05 AND VAR2>CONST(DYNAINFO(6))*0.98,VAR2,DRAWNULL);
NOTEXTGGG2:VAR3*1.046,COLORBLACK;
DRAWGBK(1,RGB(0,0,0),RGB(1,1,1),1,0,0);
NOTEXTABC:VAR3,COLORGREEN;
{分析家公式网www.88gs.com}
VAR4:=IF(VAR3<10,5,IF(VAR3>=10 AND VAR3<100,6,7));
DRAWTEXT(CURRBARSCOUNT=CONST(FROMOPEN),NOTEXTABC,VAR4),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=CONST(FROMOPEN),NOTEXTABC,STRCAT(8,CON2STR(VAR3,2))),COLORBLACK;
VAR5:=CONST((VAR3-DYNAINFO(3))/DYNAINFO(3)*100);
VAR6:=IF(FROMOPEN<230,ISLASTBAR,CURRBARSCOUNT=INTPART(FROMOPEN/2)+13);
VAR7:=IF(FROMOPEN<230,0,CURRBARSCOUNT=INTPART(FROMOPEN/2)+13);
DRAWTEXT(VAR7,NOTEXTABC,9),COLORBLACK;
DRAWTEXT(VAR6 AND VAR5<0,NOTEXTABC,STRCAT(STRCAT(10,CON2STR(VAR5,2)),11)),COLORGREEN;
DRAWTEXT(VAR6 AND VAR5>=0,NOTEXTABC,STRCAT(STRCAT(10,CON2STR(VAR5,2)),11)),COLORRED;
DRAWTEXT_FIX(前高引导公式.信号条件#DAY=1,0.34,0,0,12),COLORRED;
DRAWTEXT_FIX(前高引导公式.信号条件#DAY=1,0.34,0,0,13),COLORYELLOW;
DRAWICON(CROSS(CLOSE,NOTEXTABC),NOTEXTABC,34);
DRAWTEXT_FIX(1,0.007,0,0,14),COLORWHITE;
DRAWTEXT_FIX(1,0,0,0,15),COLORRED;
VAR8:=STRCAT(16,DYBLOCK);
VAR9:=STRCAT(VAR8,17);
VAR10:=STRCAT(VAR9,HYBLOCK);
VAR11:=STRCAT(VAR10,18);
DRAWTEXT_FIX(IF(CODELIKE(19) OR CODELIKE(20) OR CODELIKE(21) OR NAMELIKE(22),DRAWNULL,1),IF(前高引导公式.信号条件#DAY=1,0.68,0.37),0,0,VAR11),COLORCYAN;
均价:SUM(VOL*CLOSE,FROMOPEN)/SUM(VOL,FROMOPEN),COLORRED;
CLOSE,COLORWHITE;
VAR12:=1.3;
VAR13:=ZIG(1,VAR12);
VAR14:=VAR13<REF(VAR13,1) AND REF(VAR13,1)>REF(VAR13,2);
VAR15:=CONST(SUMBARS(VAR14,1));
VAR16:=CONST(REF(VAR13,VAR15));
GZWHXA:IF(CURRBARSCOUNT<=VAR15+1,VAR16,DRAWNULL),POINTDOT,COLORYELLOW;
DRAWTEXT(ISLASTBAR,GZWHXA,STRCAT(10,CON2STR(GZWHXA,2))),COLORYELLOW;
DRAWICON(CROSS(CLOSE,GZWHXA),GZWHXA,1);
VAR17:=CONST(SUMBARS(VAR14,2));
VAR18:=CONST(REF(VAR13,VAR17));
GZWHXB:IF(CURRBARSCOUNT<=VAR17+1,VAR18,DRAWNULL),POINTDOT,COLORYELLOW;
DRAWTEXT(ISLASTBAR,GZWHXB,STRCAT(10,CON2STR(GZWHXB,2))),COLORYELLOW;
DRAWICON(CROSS(CLOSE,GZWHXB),GZWHXB,1);
VAR19:=ZIG(2,VAR12);{http://www.88gs.com}
VAR20:=VAR13>REF(VAR19,1) AND REF(VAR19,1)<REF(VAR19,2);
VAR21:=CONST(SUMBARS(VAR20,1));
VAR22:=CONST(REF(VAR19,VAR21));
DZWHXA:IF(CURRBARSCOUNT<=VAR21+1,VAR22,DRAWNULL),POINTDOT,COLORGREEN;
DRAWTEXT(ISLASTBAR,DZWHXA,STRCAT(10,CON2STR(DZWHXA,2))),COLORGREEN;
VAR23:=CONST(SUMBARS(VAR20,2));
VAR24:=CONST(REF(VAR19,VAR23));
DZWHXB:IF(CURRBARSCOUNT<=VAR23+1,VAR24,DRAWNULL),POINTDOT,COLORGREEN;
DRAWTEXT(ISLASTBAR,DZWHXB,STRCAT(10,CON2STR(DZWHXB,2))),COLORGREEN;
DRAWICON(CROSS(MIN(DZWHXA,DZWHXB),CLOSE),MIN(DZWHXA,DZWHXB),2);
VAR25:=DDE数据.机构净买量#DAY;
VAR26:=DDE数据.超大#DAY;
VAR27:=DDE数据.大单#DAY;
VAR28:=DDE数据.中单#DAY;
VAR29:=DDE数据.小单#DAY;
VAR30:=IF(VAR25>=0,1,0);
VAR31:=IF(VAR26>=0,1,0);
VAR32:=IF(VAR27>=0,1,0);
VAR33:=VAR30+VAR31+VAR32;
VAR34:=VAR26>=0 AND VAR27>=0 AND VAR25>=0;
VAR35:=VAR33<3 AND VAR33>0;
VAR36:=VAR33=0;
VAR37:=0;
VAR38:=1;
VAR39:=1;
DRAWTEXT_FIX(ISLASTBAR AND VAR34=1 AND VAR39 AND DYNAINFO(10)>0,VAR37,VAR38,0,23),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND VAR34=1 AND VAR39 AND DYNAINFO(10)>0,VAR37,VAR38,0,24),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND VAR34=0 AND VAR39 AND DYNAINFO(10)>0,VAR37,VAR38,0,23),COLORGREEN;
VAR40:=IF(VAR35,25,26);
DRAWTEXT_FIX(ISLASTBAR AND VAR34=0 AND VAR39 AND DYNAINFO(10)>0,VAR37,VAR38,0,VAR40),COLORBLACK;
DRAWTEXT_FIX(ISLASTBAR AND DYNAINFO(10)>0,VAR37,VAR38,0,IF(MIN(VAR26,VAR27)>MAX(VAR28,VAR29) AND VAR25>0 AND VAR26>=0 AND VAR27>=0 AND DYNAINFO(10)>0 AND VAR39,27,DRAWNULL)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND DYNAINFO(10)>0,VAR37,VAR38,0,IF(MIN(VAR26,VAR27)<MAX(VAR28,VAR29) OR VAR25<0 OR VAR26<0 OR VAR27<0 AND DYNAINFO(10)>0 AND VAR39,27,DRAWNULL)),COLORFF8000;
DRAWTEXT_FIX(ISLASTBAR AND VAR26>=VAR27 AND VAR27>=VAR28 AND VAR28>=VAR29 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,28),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR26>=VAR27 AND VAR27>=VAR29 AND VAR29>=VAR28 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,29),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR26>=VAR28 AND VAR28>=VAR27 AND VAR27>=VAR29 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,30),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR26>=VAR28 AND VAR28>=VAR29 AND VAR29>=VAR27 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,31),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR26>=VAR29 AND VAR29>=VAR27 AND VAR27>=VAR28 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,32),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR26>=VAR29 AND VAR29>=VAR28 AND VAR28>=VAR27 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,33),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR27>=VAR26 AND VAR26>=VAR28 AND VAR28>=VAR29 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,34),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR27>=VAR26 AND VAR26>=VAR29 AND VAR29>=VAR28 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,35),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR27>=VAR28 AND VAR28>=VAR26 AND VAR26>=VAR29 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,36),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR27>=VAR28 AND VAR28>=VAR29 AND VAR29>=VAR26 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,37),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR27>=VAR29 AND VAR29>=VAR28 AND VAR28>=VAR26 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,38),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR27>=VAR29 AND VAR29>=VAR26 AND VAR26>=VAR28 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,39),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR28>=VAR26 AND VAR26>=VAR27 AND VAR27>=VAR29 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,40),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR28>=VAR26 AND VAR26>=VAR29 AND VAR29>=VAR27 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,41),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR28>=VAR27 AND VAR27>=VAR26 AND VAR26>=VAR29 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,42),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR28>=VAR27 AND VAR27>=VAR29 AND VAR29>=VAR26 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,43),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR28>=VAR29 AND VAR29>=VAR27 AND VAR27>=VAR26 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,44),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR28>=VAR29 AND VAR29>=VAR26 AND VAR26>=VAR27 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,45),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR29>=VAR26 AND VAR26>=VAR28 AND VAR28>=VAR27 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,46),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR29>=VAR26 AND VAR26>=VAR27 AND VAR27>=VAR28 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,47),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR29>=VAR27 AND VAR27>=VAR28 AND VAR28>=VAR26 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,48),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR29>=VAR27 AND VAR27>=VAR26 AND VAR26>=VAR28 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,49),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR29>=VAR28 AND VAR28>=VAR27 AND VAR27>=VAR26 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,50),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND VAR29>=VAR28 AND VAR28>=VAR26 AND VAR26>=VAR27 AND DYNAINFO(10)>0 AND VAR39,VAR37,VAR38,0,51),COLORWHITE;
VAR41:=大宗流量.DZJLRL#DAY;
VAR42:=0.547;
VAR43:=1;{http://www.88gs.com}
DRAWTEXT_FIX(VAR41<0 AND ISLASTBAR,VAR42,VAR43,0,IF(ABS(VAR41)<10,52,53)),COLORGREEN;
DRAWTEXT_FIX(VAR41<0 AND ISLASTBAR,VAR42,VAR43,0,STRCAT(STRCAT(54,CON2STR(VAR41,2)),55)),COLORBLACK;
DRAWTEXT_FIX(VAR41>=0 AND VAR41<10 AND ISLASTBAR,VAR42,VAR43,0,52),COLORRED;
DRAWTEXT_FIX(VAR41>=0 AND VAR41<10 AND ISLASTBAR,VAR42,VAR43,0,STRCAT(STRCAT(54,CON2STR(VAR41,2)),55)),COLORBLUE;
DRAWTEXT_FIX(VAR41>=10 AND ISLASTBAR,VAR42,VAR43,0,53),COLORRED;
DRAWTEXT_FIX(VAR41>=10 AND ISLASTBAR,VAR42,VAR43,0,STRCAT(STRCAT(54,CON2STR(VAR41,2)),55)),COLORYELLOW;
VAR44:=大盘涨跌家数.沪市涨#DAY;
VAR45:=大盘涨跌家数.沪市跌#DAY;
VAR46:=大盘涨跌家数.深市涨#DAY;
VAR47:=大盘涨跌家数.深市跌#DAY;
VAR48:=VAR44+VAR46;
VAR49:=VAR45+VAR47;
{分析家公式网www.88gs.com}
VAR50:=VAR48/(VAR48+VAR49)*100;
VAR51:=VAR49/(VAR48+VAR49)*100;
VAR52:=STRCAT(STRCAT(56,CON2STR(VAR50,2)),11);
VAR53:=STRCAT(STRCAT(57,CON2STR(VAR51,2)),11);
VAR54:=IF(VAR48>VAR49 AND ISLASTBAR,VAR52,VAR53);
DRAWTEXT_FIX(VAR48>VAR49 AND ISLASTBAR,0,VAR1,0,58),COLORRED;
DRAWTEXT_FIX(VAR48<VAR49 AND ISLASTBAR,0,VAR1,0,58),COLORGREEN;
DRAWTEXT_FIX(VAR48>VAR49 AND ISLASTBAR,0,VAR1,0,VAR54),COLORWHITE;
DRAWTEXT_FIX(VAR48<VAR49 AND ISLASTBAR,0,VAR1,0,VAR54),COLORBLACK;
VAR55:=(CONST(DYNAINFO(5))-MAX(CLOSE,CONST(DYNAINFO(4))))/MAX(CLOSE,CONST(DYNAINFO(4)))*100;
DRAWTEXT_FIX(VAR55>=3 AND ISLASTBAR,0.6,VAR1,0,59),COLORGREEN;
DRAWTEXT_FIX(VAR55>=3 AND ISLASTBAR,0.6,VAR1,0,STRCAT(STRCAT(60,CON2STR(VAR55,2)),11)),COLORBLACK;
 

{公式名称: MACD自编
参数数量: 1
参数1: 前高ZIG, 最小: 1, 最大: 99, 缺省: 2
画线方法: 副图
}
DRAWGBK(CLOSE>1,RGB(0,0,0),RGB(1,1,1),1,0,0);
DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
NOTEXTGG:MAX(CONST(HHV(MACD,60)),CONST(HHV(DIF,60)))*2.2,COLORBLACK;
VAR1:=ZIG(1,前高ZIG);
{分析家公式网www.88gs.com}
VAR2:=VAR1<REF(VAR1,1) AND REF(VAR1,1)>REF(VAR1,2);
VAR3:=IF(CONST(SUMBARS(VAR2,1))<=1,CONST(SUMBARS(VAR2,2)),CONST(SUMBARS(VAR2,1)));
VAR4:=CONST(REF(DIF,VAR3));
NOTEXT横线1:IF(CURRBARSCOUNT<=VAR3+1,VAR4,DRAWNULL),COLORA8A800;
DRAWTEXT(CURRBARSCOUNT=VAR3+1,NOTEXT横线1*0.9,112),COLORA8A800,LINETHICK9;
VAR5:=CONST(REF(MACD,VAR3));
NOTEXT横线2:IF(CURRBARSCOUNT<=VAR3+1,VAR5,DRAWNULL),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=VAR3+1,NOTEXT横线2*0.9,112),COLORGREEN,LINETHICK9;
 
 
通达信
 

部分公式,已缺失了调用公式,部分公式用了L2函数

下载地址(点击下图进入下载地址网页)

    重发【量价突破】(广角量价突破、主买成交量、KDJ自编、MACD自编、分时主图、选股预警公式)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网发布的公式指标和股票软件绝大部分是来源于各大论坛,例如:LX论坛,LQZ论坛,CH论坛,MA**论坛等,谢谢各位老师的原创软件。为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.61才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
* tnc和tni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne格式公式,可以用通达信公式编辑器5.0版导入,推荐通达信雨过天晴版本;
* hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式(FNC格式)大智慧股票池,同花顺公式(hxf格式),操盘手公式(daf),飞狐公式(alg),博易大师公式,文华公式等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

声明:本站所有软件和信息均免费。站内所有广告,如有收费行为,均与本站无任何关系!请广大网友小心谨慎。
Copyright © 2003-2008 88GS.Com. All Rights Reserved .
页面执行时间:3,014.64800 毫秒