分析家公式网,免费股票公式,股票软件下载站 用户登录  |  用户 注册
金尺主图
  • 软件大小:22.0 KB
  • 推荐星级:
  • 更新时间:2018-05-25 04:40:37
  • 软件类别: 国产软件 / 大智慧L2公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:金尺主图  
  • (0)0%
    (0)0%

==

 input:N(5,1,100);

MA55:MA(c,55);
A:=BARSLAST(DISPSTATUS=1)+1;
HH:=HHV(HIGH,A);
LL:=LLV(LOW,A);
上涨:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(L=LL)+1)),COLOR0000FF,linethick0;
↑空间%:(C/REF(L,上涨)-1)*100,COLOR00FFFF,linethick0;
最高%:(HHVALL(HH)/REF(L,上涨)-1)*100,COLORFF00FF,linethick0;
下跌:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(H=HH)+1)),COLOR00FF00,linethick0;
↓空间%:(C/REF(H,下跌)-1)*100,COLOR998888,linethick0;
最低%:(LLVALL(LL)/REF(H,下跌)-1)*100,COLORFF0000,linethick0;
高:REF(H,下跌),COLOR0000FF,DOTLINE;
低:REF(L,上涨),COLOR00FF00,DOTLINE;
VERTLINE(上涨=0,4),COLOR0000FF;
VERTLINE(下跌=0,3),COLOR00FF00;
DRAWTEXT(上涨=0,HHVALL(HH)*0.99,'-最高%'),COLOR0000FF;
DRAWTEXT(下跌=0,LLVALL(LL)*1.01,'-最低%'),COLOR00FF00;
DRAWTEXT(上涨=0 AND 最高%>10,LL*1.1,'-10%'),COLORYELLOW;
DRAWTEXT(上涨=0 AND 最高%>10,LL*1.15,'-15%'),COLORFFFFFF;
DRAWTEXT(上涨=0 AND 最高%>20,LL*1.2,'-20%'),COLOR00FF00;
DRAWTEXT(上涨=0 AND 最高%>25,LL*1.25,'-25%'),COLORFF00FF;
DRAWTEXT(上涨=0 AND 最高%>30,LL*1.3,'-30%'),COLOR0000FF;
DRAWTEXT(上涨=0 AND 最高%>40,LL*1.4,'-40%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>50,LL*1.5,'-50%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>60,LL*1.6,'-60%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>70,LL*1.7,'-70%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>80,LL*1.8,'-80%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>90,LL*1.9,'-90%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>100,LL*2,'-100%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>125,LL*2.25,'-125%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>150,LL*2.5,'-150%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>180,LL*2.8,'-180%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>200,LL*3,'-200%'),COLOR00FFFF;
DRAWTEXT(上涨=0 AND 最高%>250,LL*3.5,'-250%'),COLOR00FFFF;
DRAWTEXT(下跌=0 AND 最低%<-10,HH*0.9,'-10%'),COLORYELLOW;
DRAWTEXT(下跌=0 AND 最低%<-15,HH*0.85,'-15%'),COLORFFFFFF;
DRAWTEXT(下跌=0 AND 最低%<-20,HH*0.8,'-20%'),COLOR00FF00;
DRAWTEXT(下跌=0 AND 最低%<-25,HH*0.75,'-25%'),COLORFF00FF;
DRAWTEXT(下跌=0 AND 最低%<-30,HH*0.7,'-30%'),COLORFF0000;
DRAWTEXT(下跌=0 AND 最低%<-40,HH*0.6,'-40%'),COLORFFFFFF;
DRAWTEXT(下跌=0 AND 最低%<-50,HH*0.5,'-50%'),COLORFFFFFF;
DRAWTEXT(下跌=0 AND 最低%<-60,HH*0.4,'-60%'),COLORFFFFFF;
DRAWTEXT(下跌=0 AND 最低%<-70,HH*0.3,'-70%'),COLORFFFFFF;
DRAWTEXT(下跌=0 AND 最低%<-80,HH*0.2,'-80%'),COLORFFFFFF;
DRAWTEXT(下跌=0 AND 最低%<-90,HH*0.1,'-90%'),COLORFFFFFF;
DRAWTEXT(上涨=5,L,'5天'),COLOR00FFFF;
DRAWTEXT(上涨=8,L,'8天'),COLOR00FFFF;
DRAWTEXT(上涨=13,L,'13天'),COLOR00FFFF;
DRAWTEXT(上涨=21,L,'21天'),COLOR00FFFF;
DRAWTEXT(上涨=34,L,'34天'),COLOR00FFFF;
DRAWTEXT(上涨=55,L,'55天'),COLOR00FFFF;
DRAWTEXT(上涨=89,L,'89天'),COLOR00FFFF;
DRAWTEXT(上涨=144,L,'144天'),COLOR00FFFF;
DRAWTEXT(上涨=180,L,'180天'),COLOR00FFFF;
DRAWTEXT(上涨=250,L,'250天'),COLOR00FFFF;
DRAWTEXT(下跌=5,L,'-5天'),COLOR00FF00;
DRAWTEXT(下跌=8,L,'-8天'),COLOR00FF00;
DRAWTEXT(下跌=13,L,'-13天'),COLOR00FF00;
DRAWTEXT(下跌=21,L,'-21天'),COLOR00FF00;
DRAWTEXT(下跌=34,L,'-34天'),COLOR00FF00;
DRAWTEXT(下跌=55,L,'-55天'),COLOR00FF00;
DRAWTEXT(下跌=89,L,'-89天'),COLOR00FF00;
DRAWTEXT(下跌=144,L,'-144天'),COLOR00FF00;
DRAWTEXT(下跌=180,L,'-180天'),COLOR00FF00;
DRAWTEXT(下跌=250,L,'-250天'),COLOR00FF00;
{ www.88gs.com}
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
DRAWICON(CROSS(84,RSI) ,h*1.03,5);
DRAWICON(CROSS(RSI,11) ,l*0.99,4);
Var27:=REF(CLOSE,1);
Var28:=SMA(MAX(CLOSE-Var27,0),5,1)/SMA(ABS(CLOSE-Var27),6,1)*100;
DRAWICON(IF(CROSS(76,Var28),1,0),h*1.03,5);
DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),
LOW,'☆'),linethick3 , COLORff00ff;
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
aa:=SMA(VARF,3,1);
ss:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (aa>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND
(aa>ss),h*1.02,'☆'),LINETHICK3,colorgreen;
Var1:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG 有未来}
Var2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
STICKLINE(Var1,C,O,8,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(Var1,C,O,3,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(Var1,H,L,1,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(Var2,C,O,8,0),COLORFF00FF,LINETHICK2;{底位红色}
STICKLINE(Var2,C,O,3,0),COLORFF00FF,LINETHICK2;{底位红色}
STICKLINE(Var2,H,L,1,0),COLORFF00FF,LINETHICK2;{底位红色};
{ www.88gs.com}
{黄金分割线}
lhnh:=BARSLAST(DISPSTATUS=1)+1;
nnl:=DISPSTATUS=2;
Al:=BACKSET(nnl,hhvBARS(h,lhnh)+1);
Bl:=Al>REF(Al,1);
Al2:=BACKSET(nnl,LLVBARS(L,lhnh)+1);
Bl2:=Al2>REF(Al2,1); 
前高:REF(H,BARSLAST(bl)),PRECIS2,COLORff00ff,LINETHICK2;
DRAWTEXT(nnl,前高,'前高:'+前高),ALIGN2,COLORGREEN;
前低:REF(L,BARSLAST(Bl2)),PRECIS2,COLORGREEN,LINETHICK2;
DRAWTEXT(nnl,前低*1.009,'前低: '+前低),ALIGN2,COLORGREEN;
Fl1:((前高-前低)*0.191)+前低,POINTDOT,ColorFF7F93,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl1,'0.236: '+Fl1),Color938C93;
Fl2:((前高-前低)*0.382)+前低,POINTDOT,Color5E8C93,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl2,'0.382: '+Fl2),ALIGN2,COLORGREEN;
Fl3:((前高-前低)*0.5)+前低,POINTDOT,COLOR00ffff,LINETHICK4;
DRAWTEXT(nnl,Fl3,'0.5:'+Fl3),ALIGN2,Color918C93;
Fl4:((前高-前低)*0.618)+前低,POINTDOT,Color918C93,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2)and nnl,Fl4,'0.618: '+Fl4),ALIGN2,COLORGREEN;
Fl5:((前高-前低)*0.809)+前低,POINTDOT,Color918C67,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl5,'0.764: '+Fl5),ALIGN2,COLORGREEN;
 
A1:=ref(h,N)=hhv(h,2*N+1); 
B1:=filter(A1,N); 
C1:=backset(B1,N+1); 
D1:=filter(C1,n) or BARSTATUS=2;{高点}
A2:=ref(l,N)=llv(l,2*N+1); 
B2:=filter(A2,N);
C2:=backset(B2,N+1); 
D2:=filter(C2,N);{低点}
E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;
L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2);
X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars
(if(L1,l,10000),X1));
G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}
L2:=LD OR barstatus=2 OR barscount(c)=1;
X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars
(if(H2,h,0),X2));
G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点}
R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高}
T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低}
R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高}
T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低}
T3:=backset(U2,ref(barslast(LD),1)+2); U3:=T3>ref(T3,1); {前三低}
T4:=backset(U3,ref(barslast(LD),1)+2); U4:=T4>ref(T4,1); {前四低}
R3:=backset(S2,ref(barslast(HD),1)+2); S3:=R3>ref(R3,1); {前三高}
R4:=backset(S3,ref(barslast(HD),1)+2); S4:=R4>ref(R4,1); {前四高}
短期压力:drawline(S2,h,S1,h,1),Colorred,LINETHICK2;
短期支撑:drawline(U2,l,U1,l,1),Colorgreen,LINETHICK2;
中期压力:drawline(S3,h,S2,h,1),Coloryellow,LINETHICK2; 
中期支撑:drawline(U3,l,U2,l,0),Colorgreen,LINETHICK2; 
长期压力:drawline(S4,h,S3,h,1),COLORwhite,LINETHICK2;
长期支撑:drawline(U4,l,U3,l,0),Colorgreen,LINETHICK2;
DRAWICON(S1,H,10);
DRAWICON(S2,H,10); 
DRAWICON(S3,H,10);
DRAWICON(S4,H,10);

下载地址(点击下图进入下载地址网页)

    金尺主图下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网发布的公式指标和股票软件绝大部分是来源于各大论坛,例如:LX论坛,LQZ论坛,CH论坛,MA**论坛等,谢谢各位老师的原创软件。为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.61才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
* tnc和tni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式公式,可以用通达信公式编辑器5.0版导入,推荐通达信短线极品版本;
* hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式(FNC格式)大智慧股票池,同花顺公式(hxf格式),操盘手公式(daf),飞狐公式(alg),博易大师公式,文华公式等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

声明:本站所有软件和信息均免费。站内所有广告,如有收费行为,均与本站无任何关系!请广大网友小心谨慎。
Copyright © 2003-2008 88GS.Com. All Rights Reserved .
页面执行时间:406.25000 毫秒